보안뉴스 창간 17주년을 축하합니다!!

Home > 전체기사

구글 텐서플로우, 취약점 패치 위해 YAML 지원 종료

입력 : 2021-09-06 13:20
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
역직렬화 취약점 통한 임의코드실행 취약점 발견...개선 전까지 구형 버전으로 백포팅 예정

[보안뉴스 이상우 기자] 구글이 개발한 파이썬 기반 오픈소스 기계학습 및 인공지능 라이브러리 ‘텐서플로우(TensorFlow)’는 코드 실행 취약점 패치를 위해 데이터 양식인 ‘YAML’에 대한 지원을 중단한다고 밝혔다. YAML은 인간이 읽을 수 있는 언어로 데이터를 양식화하는 마크업 언어의 일종이다. 이번에 발견된 역직렬화 취약점(CVE-2021-37678)의 심각도는 9.3점으로, 공격자는 아직 직렬화되지 않은 YAML 직렬화 매커니즘을 악용해 데이터에 악의적인 페이로드를 주입하고, 임의 코드를 실행할 수 있다. 해당 패치를 수정한 텐서플로우 버전은 2.6.0으로 예상되며, 그때까지 2.5.1. 2.4.3, 2.3.4 등 구형 버전으로 백포팅 될 예정이다.

[이미지=utoimage]


[이상우 기자(boan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
 하이젠 파워비즈 23년 11월 16일~2024년 11월 15일까지 아스트론시큐리티 파워비즈 2023년2월23일 시작 위즈디엔에스 2018 넷앤드 파워비즈 진행 2020년1월8일 시작~2021년 1월8일까지
설문조사
2023년 주요 보안 위협 가운데, 올해 말까지 가장 큰 피해를 끼칠 것으로 예상되는 위협은?
공급망 공격
다크웹 기반 랜섬웨어 조직
북한/중국/러시아 등 국가 지원 해킹그룹 활동
스마트폰을 노린 보안 위협
OT 타깃 공격
피싱 공격
기타(댓글로)