Home > Security

오픈소스 삼바에 심각한 취약점 발견... 업데이트 시급

  |  입력 : 2022-02-04 11:53
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
Samba 업데이트 버전 릴리스...CVE-2021-44142 등 세 가지 취약점 해결

[보안뉴스 원병철 기자] 리눅스와 유닉스 시스템 등에서 파일 공유 및 프린트 공유에 사용되는 오픈 소스인 삼바(Samba)에 심각한 취약점이 발견돼 주의가 요구된다. 트랜드마이크로에 따르면 지난 1월 31일, Samba의 업데이트 버전이 릴리즈되어 세 가지 취약점을 해결했다. 가장 심각한 취약점(CVE-2021-44142)은 out-of-bounds heap read/write 취약점으로, 원격 공격자가 영향을 받는 버전이 설치된 디바이스에서 Root 권한으로 임의 코드를 실행할 수 있는 취약점이다.

▲Samba 업데이트 릴리즈[자료=보안뉴스 캡처]


공식 공개에 따르면 vfs_fruit(macOS 상호 운용성을 위해 사용됨)이라는 VFS 모듈의 기본 구성을 실행하는 4.13.17 이전의 모든 Samba 버전은 공격에 취약하다. 공격자는 이미 파일의 확장 속성에 대한 쓰기 액세스 권한이 있어야 하지만, 영향을 받는 서버가 이러한 유형의 사용자에 대한 쓰기 액세스를 허용하는 경우, 게스트 또는 인증되지 않은 사용자도 사용이 가능하다. 이 취약점은 원래 STAR Labs의 Nguyen Hoang Thach와 Billy Jheng Bing-Jhong이 Pwn2Own Austin 2021에서 공개했다. 그리고 트랜드마이크로 Zero Day Initiative의 Lucas Leong은 이 Fix의 부분으로서 Samba에 공개된 취약점의 추가 변종을 발견했다.

Samba는 이 취약점을 해결하기 위해 업데이트된 버전인 4.13.17, 4.14.12 및 4.15.5를 출시했다. 수동으로 해결 방법을 사용할 수 있는데, Samba 구성 파일의 ‘vfs objects’ 행에서 ‘fruit’를 제거해 VFS 모듈 설정의 기본 구성을 변경해야 한다. 그러나 이러한 설정을 변경하면 특히 macOS 클라이언트에서 저장된 정보에 액세스하지 못할 수 있다.

한편, 트렌드마이크로는 이 취약점과 관련된 잠재적인 익스플로잇 및 동작을 지속적으로 적극적으로 연구하고, 취약점에 대한 익스플로잇 시도와 관련될 수 있는 악성코드를 적극적으로 찾고 있으며, 사용 가능한 경우 추가 탐지 또는 보호 기능을 추가할 예정이라고 밝혔다.
[원병철 기자(boanone@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
아스트론시큐리티 파워비즈 2023년2월23일 시작 시큐아이 위즈디엔에스 2018
설문조사
오픈AI가 개발한 인공지능 챗봇 챗GPT가 GPT4 버전까지 나오면서 디지털 혁신의 촉매재 역할을 하고 있습니다. 보안 분야에서도 챗GPT로 인해 보안위협이 가속화될 것이라는 전망과 함께 보안업무에 효과적으로 활용된다면 보안대응 역량 향상에도 크게 기여할 것이라는 의견도 제기됩니다. 이에 대한 여러분들의 생각은 어떠신가요?
챗GPT 악용으로 인해 보안위협이 더욱 고도화되고 증가할 것
챗GPT를 악용하는데 한계가 있어 보안위협이 소폭 늘어나는 추세에 그칠 것
챗GPT 활용에 따라 보안대응 업무에 적지 않은 도움이 될 것
챗GPT의 적극적인 도입 및 적용 통해 보안대응 역량이 획기적으로 향상될 것
보안위협 또는 보안대응과 관련해서는 큰 영향이 없을 것
기타(댓글로)