Home > Security

15년된 버그, 피어 PHP 리포지터리에서 발견돼

  |  입력 : 2022-04-04 12:46
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
PHP 리포지터리에서 뒤늦게 발견된 버그...계정 침해하고 익스플로잇 가능케 해

요약 : 보안 외신 해커뉴스에 의하면 피어(PEAR)라는 유명 PHP 리포지터리에서 15년 된 버그가 발견됐다고 한다. 이 취약점을 익스플로잇 하면 아무나 악성 패키지를 배포함으로써 각종 악성 행위를 사용자의 프로젝트에 심을 수 있게 된다고 한다. 즉 공급망 공격이 가능하다는 것이다. 버그는 크게 두 가지 취약점을 가지고 있는데, 하나는 관리자 및 개발자 계정에 공격자가 접근할 수 있도록 해 주며, 또 다른 하나는 탈취된 계정을 통해 임의 코드 실행을 할 수 있게 해 준다고 한다.

[이미지 = utoimage]


배경 : 문제의 버그는 2007년 3월 만들어진 코드 커밋에서부터 발생하고 있다. 이 커밋은 mt_rand()라는 PHP 함수와 관련이 있다. 이 함수는 비밀번호 리셋과 관련된 것으로, 이 취약점 때문에 공격자는 50번 시도 내에 비밀번호 리셋 토큰을 발견할 수 있게 된다.

말말말 : “이로써 피어 리포지터리에서만 두 번째로 심각한 보안 취약점이 발견됐습니다. 2021년 4월에도 콤포저(Composer PHP)라는 패키지 관리자에서 초고위험도 취약점이 발견된 바 있거든요. 리포지터리는 최근 사이버 공격자들 사이에서 인기가 높은 공략 대상입니다.” -소나소스(SonarSource)-
[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
아스트론시큐리티 파워비즈 2023년2월23일 시작 시큐아이 위즈디엔에스 2018
설문조사
오픈AI가 개발한 인공지능 챗봇 챗GPT가 GPT4 버전까지 나오면서 디지털 혁신의 촉매재 역할을 하고 있습니다. 보안 분야에서도 챗GPT로 인해 보안위협이 가속화될 것이라는 전망과 함께 보안업무에 효과적으로 활용된다면 보안대응 역량 향상에도 크게 기여할 것이라는 의견도 제기됩니다. 이에 대한 여러분들의 생각은 어떠신가요?
챗GPT 악용으로 인해 보안위협이 더욱 고도화되고 증가할 것
챗GPT를 악용하는데 한계가 있어 보안위협이 소폭 늘어나는 추세에 그칠 것
챗GPT 활용에 따라 보안대응 업무에 적지 않은 도움이 될 것
챗GPT의 적극적인 도입 및 적용 통해 보안대응 역량이 획기적으로 향상될 것
보안위협 또는 보안대응과 관련해서는 큰 영향이 없을 것
기타(댓글로)