Home > 전체기사

애플, 페가수스 사태와 연루된 취약점 부랴부랴 패치해

  |  입력 : 2021-09-14 14:43
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기
7월의 페가수스 사태로 세상이 떠들썩해졌을 때 애플 역시 따가운 눈초리를 견뎌야만 했다. 보안이 강력하다는 홍보 문구가 무색해졌기 때문이다. 그리고 페가수스를 가능하게 한 취약점에 대해 알게 되자마자 패치를 발표했다.

[보안뉴스 문가용 기자] 애플이 iOS, iPadOS, 맥OS, 워치OS에 적용될 새로운 보안 패치를 긴급히 발표해 배포 중에 있다. 두 개의 취약점들을 패치하기 위해서인데, 애플은 권고문을 통해 “이미 활발한 익스플로잇 공격에 노출되어 있을 가능성이 있는 취약점”이라고 묘사했다.

[이미지 = utoimage]


먼저 CVE-2021-30860은 코어그래픽스(CoreGraphics)에 있는 취약점이다. 아이폰 6s와 그 후 나온 모델들, 모든 아이패드 프로 라인, 아이패드 에어 2 및 이후 모델들, 아이패드 5세대 및 이후 모델들, 아이패드 미니 4 및 이후 모델들, 아이팟 터치 7세대에 적용된다. 맥OS 빅서 11.6과 워치OS 7.6.2, 맥OS 카탈리나도 해당 취약점의 패치가 적용되어야 한다.

애플의 설명에 따르면 이 취약점은 악성 PDF를 활용하여 익스플로잇 할 수 있고, 임의 코드 실행 공격으로 이어진다고 한다. 이 취약점은 현재 공격자들이 실제 공격에 활용하고 있다는 소식이 있고, 애플도 이 부분을 인지하고 있다고 권고문에 썼다. 하지만 아직 정확한 내용(사실 여부)이 드러난 건 아니다.

이 취약점을 발견한 건 캐나다의 시티즌랩(Citizen Lab)으로, 지난 8월 애플 측에 알렸다. 바레인의 활동가들이 소유한 애플 장비들을 누군가 감염시킨 사건을 조사하다가 발견된 취약점이었다. 이 취약점은 포스드엔트리(ForcedEntry : 강제진입)라고 불리기도 한다. 이스라엘의 스파이웨어 제조사인 NSO그룹(NSO Group)이 페가수스(Pegasus)라는 스파이웨어를 심는 데에 이 취약점이 활용되었다고 한다. 또한 iOS 14부터 처음 도입된 블라스트도어(Blastdoor) 보호 장치를 우회하는 데에도 이 취약점이 이용되었다고 한다.

전 세계 여러 정부 기관들이 NSO그룹과 계약을 맺고 페가수스를 사용해온 사실이 지난 7월 국제적인 비영리 단체의 수사 활동을 통해 드러난 바 있다. 페가수스는 테러 모의자들과 범죄자들을 효과적으로 잡아내기 위해 만들어진 도구라고 NSO그룹은 주장해왔으나 실상은 많은 정부 기관들(특히 독재 정부)이 언론과 활동가, 정적들을 감시하기 위해 사용해 왔다. 이 때문에 NSO그룹은 큰 비판의 대상이 되었다.

그러면서 애플 역시 덩달아 국제적인 비판을 받게 됐다. 정보 보안과 프라이버시 보안에 있어 가장 강력한 장비를 만드는 회사인 것처럼 홍보를 해왔던 것이 무색하게 수많은 불법 감시 활동이 이뤄지고 있는데도 모르고 있었기 때문이다. 애플은 내부적으로 페가수스가 악용한 취약점을 알아내기 위해 서둘러 연구를 진행했다고 알려져 있다.

시티즌랩은 최근의 새로운 블로그 게시글을 통해 “포스드엔트리 취약점이 사우디아라비아의 활동가들의 아이폰에서 익스플로잇 되고 있음을 새롭게 발견했다”고 알리며 해당 활동가들의 장비들 역시 페가수스에 감염되어 있었다고 한다. 포스드엔트리는 제로데이 취약점이기도 하지만 제로클릭 취약점이기도 해서 매우 위험하다. 제로클릭 취약점이란, 피해자가 피싱 링크를 클릭한다거나 악성 문서를 여는 행위를 하지 않아도 익스플로잇이 된다는 뜻으로 피해자가 감염 사실을 알기가 매우 힘들다.

코어그래픽스는 애플의 이미지 렌더링 라이브러리로 iOS, 맥OS, 워치OS를 기반으로 한 모든 장비들에서 사용되고 있다. 공격자들이 이 중요한 요소의 취약점을 파악하고 실제 공격에 악용하기 시작한 건 최소 2021년 2월부터라고 시티즌랩은 보고 있다.

그 다음 취약점인 CVE-2021-30858의 경우 아이폰 6 이상 모델, 아이패드 프로 전 모델, 아이패드 에어 2 이상 모델, 아이패드 5세대 이상 모델, 아이패드 미니 4 이상 모델, 아이팟 터치 7세대에서 전부 발견되고 있으며, 따라서 이번 패치도 이 모든 장비들에 적용될 예정이다. 각 OS의 웹킷(WebKit) 요소에 존재한다.

애플은 “악의적으로 조작된 웹 콘텐츠가 웹킷을 통해 처리될 경우 임의 코드 실행 공격이 가능하게 된다”며 “이 취약점이 이미 해커들의 손에 익스플로잇 되고 있을 가능성이 있다는 소식을 인지하고 있다”고 권고문에 썼다. 이 취약점을 발견해 애플에 제보한 인물의 이름은 공개되지 않았다.

3줄 요약
1. 애플, 페가수스 사태로 망신 톡톡히 당하더니 드디어 취약점 찾음.
2. 취약점 제보를 받은 즉시 패치 내놓고 현재 배포하는 중.
3. 제로데이 취약점이 발견된 건 코어그래픽스와 웹킷이라는 OS 구성 요소.

[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
모니터랩 파워비즈 6개월 2021년7월1~12월31일 까지2021 전망보고서위즈디엔에스 2018파워비즈배너 시작 11월6일 20181105-20200131
설문조사
2021년 주요 보안 위협 트렌드 가운데 올해 말까지 가장 큰 위협이 될 것으로 전망되는 트렌드 한 가지만 꼽아주신다면?
산업 전반에 영향 미치는 타깃형 랜섬웨어 공격 증가
다크웹/딥웹 등을 통한 기업 주요 정보 유출 및 판매 피해 급증
북한/중국/러시아 등 국가지원 해킹그룹의 위협 확대
코로나 팬더믹 등 사회적 이슈 악용한 사이버 공격
서드파티 SW나 조직 인프라 솔루션을 통한 공급망 공격 증가
업무 메일로 위장한 정보유출형 악성코드 활개
기타(댓글로)