Home > 전체기사

vm2 샌드박스 라이브러리에서 초고위험도 샌드박스 탈출 취약점 발견돼

  |  입력 : 2023-04-10 11:44
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
일주일에 400만 번 다운로드 되는 초인기 라이브러리에서 발견된 초고위험도 취약점

요약 : 보안 블로그 시큐리티어페어즈에 따르면 최근 vm2라는 자바스크립트 샌드박스 모듈에서 초고위험도 취약점이 발견됐다고 한다. CVE-2023-29017이며 CVSS 기준 9.8점을 받았다. 익스플로잇에 성공한 공격자는 임의의 셸 코드를 실행할 수 있게 된다고 한다. vm2 메인테이너들은 해당 문제를 접수하고 빠르게 패치를 개발해 배포했다. 처음 발견자는 한국 카이스트의 위성일이라는 보안 연구원이라고 한다.

[이미지 = utoimage]


배경 : vm2는 Node.js 서버에서 신뢰가 충분하지 못한 코드를 실행시킬 때, 고립된 환경을 조성해 주는 샌드박스 프로그램이다. 일주일에 400만 번 이상 다운로드 될 정도로 인기가 높다. 3.9.14 이전 버전들에서 취약점이 발견되고 있으며, 3.9.15 버전부터는 문제가 해결된다고 한다. vm2에서는 지난 10월에도 샌드박스 탈출 취약점이 발견된 바 있다.

말말말 : “vm2는 특정한 조건에서 Error.prepareStackTrace에 전달된 호스트 객체들을 제대로 처리하지 못하고 있었습니다. 그러면서 취약점이 발동됐습니다.” -카이스트-
[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
아스트론시큐리티 파워비즈 2023년2월23일 시작 위즈디엔에스 2018
설문조사
오픈AI가 개발한 인공지능 챗봇 챗GPT가 GPT4 버전까지 나오면서 디지털 혁신의 촉매재 역할을 하고 있습니다. 보안 분야에서도 챗GPT로 인해 보안위협이 가속화될 것이라는 전망과 함께 보안업무에 효과적으로 활용된다면 보안대응 역량 향상에도 크게 기여할 것이라는 의견도 제기됩니다. 이에 대한 여러분들의 생각은 어떠신가요?
챗GPT 악용으로 인해 보안위협이 더욱 고도화되고 증가할 것
챗GPT를 악용하는데 한계가 있어 보안위협이 소폭 늘어나는 추세에 그칠 것
챗GPT 활용에 따라 보안대응 업무에 적지 않은 도움이 될 것
챗GPT의 적극적인 도입 및 적용 통해 보안대응 역량이 획기적으로 향상될 것
보안위협 또는 보안대응과 관련해서는 큰 영향이 없을 것
기타(댓글로)