보안뉴스 창간 17주년을 축하합니다!!

Home > 전체기사

스마트에디터 2.0 파일 업로드 취약점...보안 업데이트 필수

입력 : 2016-07-19 23:48
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
취약한 버전에서는 웹쉘 업로드 및 시스템 명령어 사용 가능

[보안뉴스 권 준] 네이버 사는 오픈 프로젝트로 제공하고 있는 ‘SmartEditor2.0 Basic’에서 파일 업로드 취약점이 발견되어 보안 업데이트를 진행했다고 밝혔다.

‘SmartEditor2.0 Basic’은 자바 스크립트(JavaScript)로 구현된 웹 기반의 위지윅(WYSIWYG) 편집기로, 글꼴, 글자 크기, 줄 간격 등을 자유롭게 설정할 수 있고, 단어 찾기 및 바꾸기와 같은 편리한 기능을 제공한다. 현재 SmartEditor3.0까지 출시된 상태다.

이번에 발견된 취약점은 파일 업로드 취약점으로, 업로드 기능을 이용하여 웹쉘(webshell) 업로드 및 시스템 명령어 사용 가능한 것으로 드러났다. 이로 인해 취약한 버전인 SmartEditor 2.0 Basic (2.8.2) 및 이전버전을 사용하고 있을 경우 홈페이지 해킹에 의해 홈페이지 변조는 물론 데이터베이스 정보 유출 등의 피해를 입을 수 있는 것으로 알려졌다.

이에 SmartEditor 2.0 Basic을 사용하는 웹 관리자들은 보안 업데이트가 적용된 상위 버전 ‘SmartEditor2.0 Basic 2.8.2.1’으로의 업그레이드가 필수적이다.

이와 관련 네이버 측은 “게시판 업로드 모듈뿐만 아니라 그림 파일을 올리는 기능을 통해 취약점이 발견되었기 때문에 사용자가 파일을 업로드 할 수 있는 모든 모듈에 업데이트 적용이 필요하다”며, “동일한 모듈을 사용하고 있는 부분이 있는지 개발단에서 확인해야 하며, 이미지 파일만 업로드가 허용된 상태라면, jpg, png, bmp, gif 파일에 대한 매직바이트(헤더)까지 비교해야 한다. 가급적이면 서버 환경 설정에서 보안을 강화할 필요가 있다”고 당부했다.

보다 자세한 사항은 한국인터넷진흥원 인터넷침해대응센터 또는 네이버 스마트에디터 홈페이지를 참조하면 된다.
[권 준 기자(editor@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 6
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
아스트론시큐리티 파워비즈 2023년2월23일 시작 위즈디엔에스 2018 넷앤드 파워비즈 진행 2020년1월8일 시작~2021년 1월8일까지
설문조사
2023년 주요 보안 위협 가운데, 올해 말까지 가장 큰 피해를 끼칠 것으로 예상되는 위협은?
공급망 공격
다크웹 기반 랜섬웨어 조직
북한/중국/러시아 등 국가 지원 해킹그룹 활동
스마트폰을 노린 보안 위협
OT 타깃 공격
피싱 공격
기타(댓글로)