Home > 전체기사

8만여 개 우커머스 사이트들, 플러그인 통해 무방비로 노출돼

  |  입력 : 2021-12-02 11:53
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
늘 플러그인이 문제인 워드프레스 우커머스...이번에 8만 사이트가 위험

요약 : 워드프레스 기반 전자상거래 플랫폼인 우커머스(WooCommerce)로 만들어진 웹사이트들에서 취약점이 발견됐다. 보다 정확히 말하자면, 우커머스 사이트 8만여 개에 설치된 유명 플러그인이 문제의 진원지이다. 이 플러그인은 Variation Swatches for WooCommerce이며, 여기서 발견된 취약점은 일종의 XSS 취약점이다. 공격자가 웹사이트를 장악할 수 있게 해 준다.

[이미지 = utoimage]


배경 : 워드프레스는 현존하는 사이버 생태계에서 적잖은 비율을 차지하고 있다. 그런데 매달 빠지지 않고 심각한 보안 문제가 발견된다. 주 원인은 워드프레스용 플러그인들이다. 워드프레스 사용자들이라면 반드시 플러그인 업데이트 소식에 민감해져야 한다.

말말말 : “이번에 문제가 된 플러그인은 같은 제품의 다양한 버전들을 한 번에 모아서 볼 수 있게 해 주는 기능을 가지고 있습니다. 쇼핑을 할 때 대단한 편의성을 제공하지요. 그래서 ‘취약하니 언인스톨 하라’고 간단히 말하기가 힘듭니다.” -워드펜스-
[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
아스트론시큐리티 파워비즈 2023년2월23일 시작 시큐아이 위즈디엔에스 2018
설문조사
오픈AI가 개발한 인공지능 챗봇 챗GPT가 GPT4 버전까지 나오면서 디지털 혁신의 촉매재 역할을 하고 있습니다. 보안 분야에서도 챗GPT로 인해 보안위협이 가속화될 것이라는 전망과 함께 보안업무에 효과적으로 활용된다면 보안대응 역량 향상에도 크게 기여할 것이라는 의견도 제기됩니다. 이에 대한 여러분들의 생각은 어떠신가요?
챗GPT 악용으로 인해 보안위협이 더욱 고도화되고 증가할 것
챗GPT를 악용하는데 한계가 있어 보안위협이 소폭 늘어나는 추세에 그칠 것
챗GPT 활용에 따라 보안대응 업무에 적지 않은 도움이 될 것
챗GPT의 적극적인 도입 및 적용 통해 보안대응 역량이 획기적으로 향상될 것
보안위협 또는 보안대응과 관련해서는 큰 영향이 없을 것
기타(댓글로)