Home > 전체기사
아래한글 임의코드 실행 취약점 발견!
  |  입력 : 2013-11-03 02:12
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기
한글·한/셀 등 오피스 프로그램에서 취약점 2건...보안업데이트 필수 


[보안뉴스 권 준] 한글과컴퓨터 사의 아래한글 등 오피스 프로그램에서 임의코드 실행이 가능한 취약점이 발견됐다.


이번에 발견된 취약점은 한글(Hwp) ActiveX Control 취약점, 한/셀 버퍼오버플로우 취약점 등 크게 두 가지다.


공격자가 이번 취약점을 악용할 경우 특수하게 조작한 웹페이지 방문 유도 또는 웹 게시물, 메일, 메신저의 링크 등을 통해 특수하게 조작된 한글문서를 열어보도록 유도하여 임의코드를 실행시킬 수 있다.


이로 인해 아래 영향 받는 버전의 사용자는 악성코드 감염에 취약할 수 있으므로 보안업데이트를 진행해야 한다.


<한컴오피스 2010 SE+>

- 한컴오피스 2010 SE+ 공통 요소 : 8.5.8.1455 및 이전 버전

- 한/글 2010 SE+ : 8.5.8.1375 및 이전 버전

- 한/쇼 2010 SE+ : 8.5.8.1437 및 이전 버전

- 한/셀 2010 SE+ : 8.5.8.1292 및 이전 버전


<한글과컴퓨터 오피스 2007>

- 한글과컴퓨터 오피스 공통 요소 : 7.5.12.673 및 이전 버전

- 한/글 2007 : 7.5.12.674 및 이전 버전

- 슬라이드 : 7.5.12.883 및 이전 버전

- 넥셀 : 7.5.12.739 및 이전 버전


이번 취약점을 해결하기 위해서는  한글과컴퓨터 사의 패치 업데이트 홈페이지(http://www.hancom.co.kr/downLoad.downPU.do?mcd=001) 코너에서 보안업데이트 파일을 직접 다운로드 받아 설치하여 아래 버전으로 업데이트 하거나 한글과컴퓨터 자동 업데이트(시작 → 모든 프로그램 → 한글과컴퓨터 → 한글과컴퓨터 자동 업데이트)를 통해 최신 버전으로 업데이트 하면 된다.


<한컴오피스 2010 SE+>

- 한컴오피스 2010 SE+ 공통 요소 : 8.5.8.1459 및 이상 버전

- 한/글 2010 SE+ : 8.5.8.1382 및 이상 버전

- 한/쇼 2010 SE+ : 8.5.8.1444 및 이상 버전

- 한/셀 2010 SE+ : 8.5.8.1299 및 이상 버전


<한글과컴퓨터 오피스 2007>

- 한글과컴퓨터 오피스 공통 요소 : 7.5.12.674 및 이상 버전

- 한/글 2007 : 7.5.12.676 및 이상 버전

- 슬라이드 : 7.5.12.884 및 이상 버전

- 넥셀 : 7.5.12.740 및 이상 버전


한편, 한글(Hwp) ActiveX Control 취약점은 한국인터넷진흥원 인터넷침해대응센터(KrCERT) 홈페이지를 통해 lokihardt@ASRT 씨가 한/셀 임의코드 실행 취약점은 임성열(limsy) 씨가 제공해 알려졌다.

[권 준 기자(editor@boannews.com)]


<저작권자: 보안뉴스(http://www.boannews.com/) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기


  •  SNS에서도 보안뉴스를 받아보세요!! 
넷앤드 파워비즈 진행 2020년1월8일 시작~2021년 1월8일까지위즈디엔에스 2018파워비즈배너 시작 11월6일 20181105-20200131
설문조사
코로나19 사태로 인해 화상회의, 원격교육 등을 위한 협업 솔루션이 부상하고 있습니다. 현재 귀사에서 사용하고 있는 협업 솔루션은 무엇인가요?
마이크로소프트의 팀즈(Teams)
시스코시스템즈의 웹엑스(Webex)
구글의 행아웃 미트(Meet)
줌인터내셔녈의 줌(Zoom)
슬랙의 슬랙(Slack)
NHN의 두레이(Dooray)
이스트소프트의 팀업(TeamUP)
토스랩의 잔디(JANDI)
기타(댓글로)