Home > 전체기사
메드트로닉에서 출시한 의료 장비 일부에서 취약점 다수 나와
  |  입력 : 2019-11-11 11:12
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기
디도스, 파일 덮어쓰기, 원격 코드 실행 등을 가능케 해주는 취약점
국토안보부도 경고...메드트로닉은 “보안 수칙 사항 잘 지키면 사용해도 무방”


[보안뉴스 문가용 기자] 의료 장비 제조사인 메드트로닉 밸리랩(Medtronic Valleylab)에서 출시한 제품들에서 치명적으로 위험한 취약점들이 발견됐다. 공격자들이 파일을 덮어쓰기 하고, 원격에서 코드를 실행할 수 있게 해주는 취약점이라고 미국 국토안보부가 발표했다.

[이미지 = iclickart]


국토안보부 산하 사이버 보안 전담 기관인 CISA에 의하면 메드트로닉 밸리랩 FT10과 FX8 장비에서 네 개의 취약점이 발견되었다고 한다. 이를 익스플로잇 하는 데 성공할 경우 공격자들은 넌루트 셸(non-root shell)을 설치할 수 있게 된다.

위 장비들은 디폴트 상 네트워크나 인터넷에 연결되어 있어서는 안 되는 제품이다. 또한 리부트를 하게 되면 이더넷 포트가 자동으로 비활성화 되기도 한다. 그러나 실제 현장에서 사용될 때는 인터넷 및 네트워크와의 연결이 흔히 이뤄지며, 따라서 공격자에게 노출되는 일이 드물지 않다고 한다.

문제의 장비들은 하드코드 된 크리덴셜을 여러 개 내포하고 있다. 공격자들에게 노출되었을 경우 공격자들의 파일들에 대한 접근이 자유로워진다. 이는 세 가지 취약점 중 첫 번째로, CVE-2019-13543라는 번호를 부여받았으며, CVSS 점수는 5.8점을 받았다.

두 번째 취약점은 CVE-2019-13539로, OS 비밀번호 해싱에 해독 알고리즘이 사용된다는 점이다. 네트워크 기반의 로그온이 비활성화 되어 있다고 하더라도 이 취약점을 익스플로잇 하는 게 가능하고, 성공할 경우 로컬 셸 접근 권한을 취득해 비밀번호 해시들을 알아낼 수 있게 된다고 한다. 이 취약점은 CVSS 점수 기준 7.0점을 받았다.

또한 문제가 되는 제품들에 탑재된 rssh 유틸리티 역시 취약한 버전인 것으로 밝혀졌다. rssh 유틸리티는 파일 업로드를 가능케 해주는 것으로, 공격자들이 취약점을 통해 파일들에 대한 관리자 접근 권한을 얻어내거나, 임의 코드를 실행할 수 있게 된다. 관리자 접근 권한을 가져가게 하는 취약점은 CVE-2019-3464, 임의 코드 실행 취약점은 CVE-2019-3463이며, 둘 다 CVSS 기준 9.8점을 받았다.

이 취약점들에 영향을 받는 건 밸리랩 익스체인지 클라이언트(Valleylab Exchange Client) 3.4 및 이하 버전, 밸리랩 FT10 에너지 플랫폼(Valleylab FT10 Energy Platform, VLFT10GEN) 소프트웨어 4.0.0 및 이하 버전, 밸리랩 FX8 에너지 플랫폼(VLFX8GEN) 소프트웨어 1.1.0 및 이하 버전이라고 한다.

메디트로닉 측은 먼저 FT10 플랫폼에 대한 패치를 마련해 배포하기 시작했다. FX8 플랫폼에 대한 패치는 2020년 초반부에 개발 완료될 예정이라고 한다. 그러면서 장비를 사용하는 의료진들에게 “계속해서 사용해도 안전하다”는 메시지를 전달했다. 다만 “장비를 병원 내부 네트워크에, 꼭 필요할 때만 연결하고, 그렇지 않을 때는 연결을 해제하는 안전 수칙은 반드시 지켜달라”고 당부했다.

그런데 국토안보부는 두 개의 취약점에 대한 경고문을 추가로 발표했다. 밸리랩 FT10 에너지 플랫폼 2.1.0 및 이하 버전과 2.0.3 및 이하 버전, 밸리랩 LS10 에너지 플랫폼 1.20.2 및 이하 버전에서 발견된 취약점들이라고 한다.

“이 두 가지 취약점들은 RFID 보안 메커니즘에 영향을 주며, 익스플로잇에 성공할 경우 공격자들이 인증 되지 않은 장비를 해당 제품들에 연결할 수 있게 됩니다. 장비 퍼포먼스에 있어서 무결성이 훼손될 수 있고, 플랫폼을 사용하지 못하는 상태에 이를 수도 있게 됩니다.”

이 취약점들은 각각 CVE-2019-13531과 CVE-2019-13535로, 전자는 4.8점, 후자는 4.6점을 받았다. 패치가 이미 나온 상태다. 메드트로닉은 추가로 경고 대상이 된 장비에 대해서도 “계속해서 사용해도 안전하다”는 메시지를 전달하고 있다. 다만 “소프트웨어를 가장 최신 버전으로 업그레이드 해야 한다”고 권고했다.

3줄 요약
1. 메드트로닉 사에서 만든 장비 일부에서 취약점 다수 발견됨.
2. 밸리랩 FT10과 FX8 제품에서 발견된 것들로, 미국 국토안보부까지 경고문 발표.
3. FT10 제품에 해당하는 패치는 배포 중. FX8 제품의 패치는 내년 초에배포 예정.

[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기


  •  SNS에서도 보안뉴스를 받아보세요!! 
그린존시큐리티 4개월 배너모니터랩 파워비즈 6개월 2020년6월22~12월 22일 까지넷앤드 파워비즈 진행 2020년1월8일 시작~2021년 1월8일까지위즈디엔에스 2018파워비즈배너 시작 11월6일 20181105-20200131
설문조사
코로나19 팬더믹 이후, 가장 기승을 부리고 있는 사이버 공격 유형은 무엇이라고 보시나요?
랜섬웨어
피싱/스미싱
스피어피싱(표적 공격)/국가 지원 해킹 공격
디도스 공격
혹스(사기) 메일
악성 앱
해적판 소프트웨어
기타(댓글로)